403 forbidden on homepage

Hi, I am using two different homepages for anonymous user and logged in user. Anon user - custom html added in theme settings (/admin/appearance/settings/theme) Logged in user - dashboard Problem is that, for anon user, http error code 403 is shown. Here are the screenshots from chrome developer tools - network tab http://imgur.com/Jqb9Bq0 If I uncheck - "Use a different homepage for anonymous users." from theme settings, then I get a blank homepage for anon user with a message - "You are not authorized to access this page." Google too is not able to crawl homepage. How do I go about solving this? Thank you, Rahul D.



If the homepage you want for anonymous users can be composed inside the text area available in the display settings, then check the option "Use a different homepage for anonymous users" and enter the content of this page inside the text area.

Otherwise, try to adjust the default 403 page in <your platform url>/admin/config/system/site-information

in order to redirect to your default anonymous homepage

Best regards,


Hi Axel,

Hi Axel, I did the same. I was using "Use a different homepage for anonymous users" option. But it gave me 403 error and at the same time, loaded the page correctly. So, I get 403 error in headers of the site but you can't say it looking at the loaded html. I used front page module to load different hompage for anonymoous users. Somehow Opigno's default option for different homepage doesn't seem to work. Thanks!