WYSIWYG Templates empty

Running Opigno v1.23. When I try using a WYSIWYG template inside a slide, all i get is "Array". In admin/config/content/wysiwyg-templates, when I edit any template, the only code is the word "Array", Basically all the templates are empty. Should I uninstall / install the WYSIWYG Template App?

Hi asikuy,

Hi asikuy,

Yes, you should try to completey uninstall this app (by going to /admin/modules/uninstall)  then install it again.

I just tested on a Opigno 1.23 platform and it works nice

Please let us know if reinstalling the app solved your problem

Best regards


Opigno Features Roles

In the Modules/Uninstall page it says it has to uninstall the Opigno Features Roles before uninstalling the Opigno WYSIWYG Templates. How will this affect current users?

Missing templates

I get the same results running Opigno on Acquia Dev Desktop. ..

hello guys!

hello guys! I love Opigno and I'm currently setting up my site. I ran into the same problem as TS. I tried to uninstall the app but still no joy. Can you specify each step to succesfully implement the solution? thanks a lot



I found out that there is a recent bug on the install of the module Opigno WYSIWYG Templates App.

To fix it, you will need to execute some PHP code. To be able to do that, you need to install first the devel module: https://www.drupal.org/project/devel

Then, go to the path "devel/php" and copy past this code in the text area "PHP code to execute":

// ------------------------------------------------------------------------------------------ $templates = array( 'circular_flow' => array( 'title' => t("Circular flow"), 'description' => t("A circular flow with 4 steps"), ), 'gallery' => array( 'title' => t("Gallery"), 'description' => t("An image gallery"), ), 'image_text' => array( 'title' => t("Image - Text"), 'description' => t("Two columns: image + text"), ), 'matrix_2x2' => array( 'title' => t("Matrix 2x2"), 'description' => t("A matrix 2x2"), ), 'post_it' => array( 'title' => t("Post-it"), 'description' => t("Post-it note"), ), 'process' => array( 'title' => t("Process"), 'description' => t("Process with different steps"), ), 'process_2' => array( 'title' => t("Process 2"), 'description' => t("Another kind of process template"), ), 'progress' => array( 'title' => t("Progress"), 'description' => t("A progress diagram"), ), 'pyramid' => array( 'title' => t("Pyramid"), 'description' => t("Pyramid structure of data"), ), 'table' => array( 'title' => t("Table"), 'description' => t("An horizontal table"), ), 'table_2' => array( 'title' => t("Table 2"), 'description' => t("Another kind of table with many cells"), ), 'two_columns' => array( 'title' => t("Two columns"), 'description' => t("2 columns of text"), ), 'vertical_channel' => array( 'title' => t("Vertical channel"), 'description' => t("Vertical channel with arrows"), ), ); $dirname = DRUPAL_ROOT.'/profiles/opigno_lms/modules/opigno/opigno_wt_app'; $logo_path = $dirname .'/img/logo.png'; foreach ($templates as $name => $info) { $html = file_get_contents($dirname . DIRECTORY_SEPARATOR . 'wysiwyg_templates' . DIRECTORY_SEPARATOR . $name . '.html'); $info['name'] = $name; $info['fid'] = 0; $info['body'] = str_replace('[INSERT_LOGO_PATH]', $logo_path, $html); $info['format'] = 'html'; wysiwyg_template_save_template($info); } // ------------------------------------------------------------------------------------------

Finally, click on the "Execute" button at the bottom of the page.

Now the templates should work again. This will be fixed on the next release of Opigno.

Best regards,