Webex configuration not working

Hi My Webex Configuration of the opigno app is correct. It is working with Demo credentials, but I have bought a new subscription to Webex. Using those credentials I got XML API enabled I have site id partner Id etc. But when I try with this configuration, I am unable to schedule meetings. This is the message I am getting "Could not create/edit meeting, Webex service down or configuration incorrect"
James Aparicio

Hi srprasanna,

Hi srprasanna,

This can be caused by several things, for example you set on webex custom password requirements for meeting passwords that you have not met when trying to create the node on Opigno.

1st -> To know what is happening download and install/enable the devel module (to show debug information):


(If you are not doing this as user 1, you have to give permission to the role of the user you are using to be able to see the debug information)

2d -> Inside the file sites/all/modules/opigno_webex_app/WebexAPI.class.php you have a function called 


add the following line before the return of the function

dpm($response,"response");   The next time you try to create a webex meeting, you will also see the response that the webex server is sending. Best regards

You were right !!!! I changed

You were right !!!! I changed the password settings and it worked. Thanks for your quick update
James Aparicio

If you want to keep those

If you want to keep those seetings you can implement a hook_form_alter, and add a validation function that matches the requirements that you have on the webex configuration.

Best regards



Hi I am using Opigno 2.1. Does Opigno support Webex? Couldn't find module "opigno_webex_app" for Drupal 8. Thanks