Slide not showing in lesson after changing from quiz to mix in lesson

Profile picture for user luc
Hi there, I just made a lesson and discovered that after the lesson was made i had set the the Lesson type wrong was the default (quiz) and should have been Mix. I have altered the lesson type to Mix and then added a slide as a new "question"in the lesson. When i go through the lesson the text enterd in the bodyfield is not showing see The question is published I am not sure if the issue is related to the altering of the Lesson Type but it might be. Anybody a clue what the reason could be ? and how to alter it
Profile picture for user James Aparicio
James Aparicio

Hi Luc,

Hi Luc,

You probably have been changing the question display mode for that specific content type.

You should go to structure -> content types -> slide -> manage display -> question. There you select the diferent fields that should display when viewing a slide in a lesson context.

Also, it might be the case that you created the slide empty, started the lesson but didnt finish it, edited the slide and then resumed the lesson. In that case you are still viewing the old version and have to finish the lesson before viewing the changes.


Best regards

Profile picture for user luc

Big thanks

James, It did the trick I am not sure how this got altered ( i think it was still the 1.21 distro) but nevermind it works now :-)

Same problem, not resolved

Hi, I have the same issue (slide content in a mixed lesson not displayed to student) but both of your suggestions haven't worked out. Here is a screenshot with the display options in case I got something wrong: (sorry for some Russian, couldn't change the link - but it's the Question section). What's interesting, I have full access to slides and courses content as a coordinator, everything is displayed properly. And as a student I can't even see the description of the course. Blank page - that's it. There is also an issue with course logo upload but it doesn't seem to be relevant to the point.