Invalid argument supplied

Hi, I ran into a crash on my Opigno installation and tried to restore it from backups I had made. I deleted all the old files system, except for the sites/default structure which contains some php settings files - i.e. shared hosting system/php would not let me delete them. I then extracted the filesystem back-up into the original site, although I did nothing with the sql database which, was already installed / same as before. Everything seems to work OK except for a couple of strange issues that suddenly materialised whilst working on the LMS. Although I have administrator rights (double checked twice in permissions), it is now denying me access to the Appearance/Manage Display Settings option in the Opigno Administration menu. I have no idea why or how best to correct this. I can see no way to do it through the Opigno permissions interface, so that means I have to use chmod via C-Panel. Whilst I understand the system in unix permissions principle, I have no idea which file or directory to look for or to which settings the corrupted permissions should be reset to. I then also started getting the following warning messages... Invalid argument supplied:- Warning: Invalid argument supplied for foreach() in opigno_collaborative_workspaces_form_node_form_alter() (line 46 of /home/liikanjitsu/public_html/ Warning: Invalid argument supplied for foreach() in opigno_class_app_views_query_alter() (line 408 of /home/liikanjitsu/public_html/ I have not signed up for the free trial on the workspaces yet, so that may have something to do with the first error message. However, I have not touched the opigno:class:app module at all. In both cases I did not notice any such error messages in the original instance before I restored from back-up. Can anyone give me any pointers? Kr, Chris