6 posts / 0 new
Last post
Naujoël
Offline
Last seen: 5 months 3 weeks ago
Joined: 03/02/2019
Fresh installation and strange behaviors

Hello,

I have made a fresh installation of Opigno with Composer on Debian 8 and I have obtained the following strange behaviors:

1) As I read in another thread, the messages are not deleted when they are marked as read, in fact it does not change the state when marking as read.

2) In basic configurations of the site, the base address http://lms.example.com/web is determined, however, if we type http://lms.example.com in a browser it does not redirect to the base page and the error 403 Forbidden appears. This error also affects the training subscription link that is sent to the user. However, it does not affect the user registration link. In the first case, a link of the type is received: http://lms.example.com/web/user/reset/21/1551519375/QqA9LYViwcLBJ08CcAZC... While in the second case a link of the type is received: http://lms.example.com/group/2

Are they really strange behavior of the platform or is it due to some misconfiguration on my part?

Thank you for your attention.

axel
Offline
Last seen: 5 hours 21 min ago
Staff
Joined: 09/25/2013
Hi Naujoël,

Hi Naujoël,

How did you configure your Apache virtualhost ?

What did you define as a documentroot ? It should be the web subfolder where composer installed Opigno

Naujoël
Offline
Last seen: 5 months 3 weeks ago
Joined: 03/02/2019
Hi, thanks for your quick

Hi, thanks for your quick response.

I have tried to configure Virtualhost in two ways:

1) if documentroot is .../lms then it works as described in the previous comment.

2) if documentroot is .../lms /web then "web" is repeated on the site, in this way lms.example.com/web/web/admin/...

axel
Offline
Last seen: 5 hours 21 min ago
Staff
Joined: 09/25/2013
You should use second option.

You should use second option.

Did you change something in .htaccess for rewritebase ?

Did you also clear the caches (Opigno + your browser) ?

Naujoël
Offline
Last seen: 5 months 3 weeks ago
Joined: 03/02/2019
Hello,

Hello,

I have checked the htaccess of the web folder and it is the original of the installation.

Now I use the second option in Virtualhost, that is, documentroot is .../lms/web.

I have removed the "trusted hot" instruction from the settings.php file for test, then I have executed cron and cleared the caches. But the address lms.example.com keeps giving error 403 Forbbiden.

Finally, I have re-enabled the "trusted host" instruction and it has the same behavior.

P.D. The default base page of the site is: https://lms.example.com/web and it can not be changed.

garthphilpot
garthphilpot's picture
Offline
Last seen: 2 months 2 weeks ago
Joined: 10/09/2017
also..

I also have that issue with the notifications not clearing... also, if i click messages, and try to compose a new message system returns an error.