9 posts / 0 new
Last post
5okrates
5okrates's picture
Offline
Last seen: 2 months 3 days ago
Joined: 06/10/2018
Version 2.6 needs fixes

First issue
After updating from 2.5 to 2.6 my site was working, but not loading css. The problem is that you must have left hardcoded paths to the development service: link rel="stylesheet" media="all" href="http://opigno-d8:8080/main.css"
script src="http://opigno-d8:8080/vendor.js"
script src="http://opigno-d8:8080/main.js"
And since I'm using HTTPS those files cannot be loaded.

Second issue
While installing 2.6 from scratch, there are errors due to missing directories:

The directory public://media-icons/generic does not exist. An automated attempt to create this directory failed, possibly due to a permissions problem. To proceed with the installation, either create the directory and modify its permissions manually or ensure that the installer has the permissions to create it automatically. For more information, see INSTALL.txt or the online handbook.
Writable (public download method) The directory sites/default/files does not exist. An automated attempt to create this directory failed, possibly due to a permissions problem. To proceed with the installation, either create the directory and modify its permissions manually or ensure that the installer has the permissions to create it automatically. For more information, see INSTALL.txt or the online handbook.
Private file system path not set Your uploaded files are not fully protected because you did not set a Private File Directory. You need to set an existing local file system path for storing private files. It should be writable by Drupal and not accessible over the web. This must be changed in settings.php. More info: https://opigno.atlassian.net/wiki/spaces/OUM20/pages/743636993/Enable+pr...

nikolay
Offline
Last seen: 1 month 3 weeks ago
Joined: 12/12/2018
Hi, 5okrates.

Hi, 5okrates. For the first issue - did you try to clear the cache after updating?

For the second issue - these error messages notify you about all requirements that should be configured before Drupal run the installation process (you need just create "files" folder in "sites/default/" and configure private system for Opigno (how to do this you can find in https://opigno.atlassian.net/wiki/spaces/OUM20/pages/743636993/Enable+pr...)

5okrates
5okrates's picture
Offline
Last seen: 2 months 3 days ago
Joined: 06/10/2018
Nikolay, thank you for your

Nikolay, thank you for your reply.
1. Yes, I have cleared all caches. If fact, it was my first thought when I saw site with no css applied. I'm not a Drupal expert, but why would any cache point to "http://opigno-d8:8080/main.css" in site source html?
2. I could create and set all 3 paths manually, but: a) it was not required previously, b) it is not mentioned in the manual (section installation), so I assume it is an oversight.

axel
Offline
Last seen: 1 hour 58 min ago
Staff
Joined: 09/25/2013
Hi 5okrated

Hi 5okrated

For point 1, can you try to go to Platon settings (/admin/appearance/settings/platon)

and then to check the option "Enable BrowserSync support for theme" (at the bottom of the interface), then save, then disable this option, and then save again.

This should flush caches.

timotheonb
Offline
Last seen: 3 days 21 hours ago
Joined: 12/07/2017
Worked.

Thanks, this worked for me.

5okrates
5okrates's picture
Offline
Last seen: 2 months 3 days ago
Joined: 06/10/2018
Worked

Thank you Axel. This solution has worked for me, too.

5okrates
5okrates's picture
Offline
Last seen: 2 months 3 days ago
Joined: 06/10/2018
One more minor bug

When you try to name any activity like this:
"Кухня - 1 серия - часть 1 - Найди соответствия"
You get an error - unexpected error or not able to write to database.
When you use English letters or shorter name, there is no error.
This error may be specific to version 2.6, but I'm not sure. I do not have a working 2.5 version.

axel
Offline
Last seen: 1 hour 58 min ago
Staff
Joined: 09/25/2013
Thanks for the feedback, and

Thanks for the feedback, and happy that it solved your issue.

We will investigate why this cache problem occurs for theme, and how we could avoid it during upgrades.

@5okrates: I can reproduce the issue with the title that you mentioned. It gives an error that the title is too long, but it's not too long, so it's another issue, we have to further investigate. We will keep you updated.

axel
Offline
Last seen: 1 hour 58 min ago
Staff
Joined: 09/25/2013
Hi 5okrates,

Hi 5okrates,

Issue with title of activities will be fixed in the next version of Opigno.

Here is a patch if you want to fix it in the meantime: https://www.opigno.org/opigno_activity_encode_issue.patch