6 posts / 0 new
Last post
ehbowen
Offline
Last seen: 3 weeks 5 days ago
Joined: 09/06/2018
Upgrading generic Drupal 8 install to Opigno?

I'm wanting to do an install of Opigno for test and development purposes on a Synology NAS. Unfortunately, Synology is infamous for making undocumented changes to configuration files and such which break user-installed packages. However, they do have and support a generic Drupal 8 install through their package manager, and once installed you can add plugins and themes as required and the configuration should remain stable.

Is it possible to take a generic Drupal 8 install such as this and add in the requisite modules and files necessary to upgrade it to a working version of Opigno? If so, does anyone have a laundry list of what I would need to add and activate?

axel
Offline
Last seen: 6 days 9 hours ago
Staff
Joined: 09/25/2013
Hi,

Hi,

It's possible but will require a lot of work to enable all the modules, apply patches, and manually configure all settings.

We don't have any list of steps to follow, but you can have a look at the installation profile of Opigno LMS distribution to know what has to be done.

We highly recommend using the distribution, that will very easily install.

ehbowen
Offline
Last seen: 3 weeks 5 days ago
Joined: 09/06/2018
Problems encountered installing with Composer

I decided to give the installation one more try using Composer, and I think that I'm most of the way there. But not all of the way there. I get the following warning messages:

"https://ehbowen.net/photobucketpix/Screenshot_2019-08-22-Requirements-pr..."

How do I resolve this? I can't find a ggroup module on Drupal 8, and I'm not sure where the "PUBLIC:" directory is supposed to be.

axel
Offline
Last seen: 6 days 9 hours ago
Staff
Joined: 09/25/2013
Hi 

Hi 

We cannot reproduce this issue.

Did you follow the instruction in our user manual to install Opigno with composer ?

ehbowen
Offline
Last seen: 3 weeks 5 days ago
Joined: 09/06/2018
Yes, I did follow the

Yes, I did follow the instructions for installing Opigno with composer. My problem seems to be that Composer, on my machine, has difficulty installing patches. Here's the output of "composer install" from the base Opigno directory:

Gathering patches for root package. Removing package drupal/core so that it can be re-installed and re-patched. - Removing drupal/core (8.7.2) Deleting web/core - deleted Removing package drupal/entity_print so that it can be re-installed and re-patched. - Removing drupal/entity_print (2.0.0) Deleting web/modules/contrib/entity_print - deleted Removing package drupal/group so that it can be re-installed and re-patched. - Removing drupal/group (1.0.0-rc2) Deleting web/modules/contrib/group - deleted Removing package drupal/h5p so that it can be re-installed and re-patched. - Removing drupal/h5p (1.0.0-rc14) Deleting web/modules/contrib/h5p - deleted Removing package drupal/private_message so that it can be re-installed and re-patched. - Removing drupal/private_message (2.0.0-beta15) Deleting web/modules/contrib/private_message - deleted Removing package drupal/video so that it can be re-installed and re-patched. - Removing drupal/video (1.4.0) Deleting web/modules/contrib/video - deleted > DrupalProject\composer\ScriptHandler::checkComposerVersion Loading composer repositories with package information Installing dependencies (including require-dev) from lock file Package operations: 6 installs, 0 updates, 0 removals Gathering patches for root package. Gathering patches for dependencies. This might take a minute. As there is no 'unzip' command installed zip files are being unpacked using the PHP zip extension. This may cause invalid reports of corrupted archives. Besides, any UNIX permissions (e.g. executable) defined in the archives will be lost. Installing 'unzip' may remediate them. - Installing drupal/core (8.7.2): Loading from cache - Applying patches for drupal/core https://www.drupal.org/files/issues/2019-04-15/2924061-14.patch (2924061) Could not apply patch! Skipping. The error was: Cannot apply patch https://www.drupal.org/files/issues/2019-04-15/2924061-14.patch https://www.drupal.org/files/issues/2018-04-20/views-code_bundle_fields-2898635-16.patch (2898635) Could not apply patch! Skipping. The error was: Content-Length mismatch, received 0 bytes out of the expected 2471

  • Installing drupal/entity_print (2.0.0): Loading from cache
  • Applying patches for drupal/entity_print https://www.drupal.org/files/issues/2018-05-03/entity_print-dompdf-2969184.patch (2969184) Could not apply patch! Skipping. The error was: Cannot apply patch https://www.drupal.org/files/issues/2018-05-03/entity_print-dompdf-2969184.patch

  • Installing drupal/group (1.0.0-rc2): Loading from cache

  • Applying patches for drupal/group https://www.drupal.org/files/issues/2018-04-20/2736233-156.patch (2736233) Could not apply patch! Skipping. The error was: Cannot apply patch https://www.drupal.org/files/issues/2018-04-20/2736233-156.patch https://www.drupal.org/files/issues/2018-05-15/group-2973005-2.patch (2973005) Could not apply patch! Skipping. The error was: Cannot apply patch https://www.drupal.org/files/issues/2018-05-15/group-2973005-2.patch

  • Installing drupal/h5p (1.0.0-rc14): Loading from cache

  • Applying patches for drupal/h5p https://www.drupal.org/files/issues/2019-07-09/opigno-module-h5p-hidetitle-3018798-6.patch (3018798) Could not apply patch! Skipping. The error was: Cannot apply patch https://www.drupal.org/files/issues/2019-07-09/opigno-module-h5p-hidetitle-3018798-6.patch

  • Installing drupal/private_message (2.0.0-beta15): Loading from cache

  • Applying patches for drupal/private_message https://www.drupal.org/files/issues/2018-07-03/private-message-2961332-2.0.patch (2961332) Could not apply patch! Skipping. The error was: Cannot apply patch https://www.drupal.org/files/issues/2018-07-03/private-message-2961332-2.0.patch

  • Installing drupal/video (1.4.0): Loading from cache

  • Applying patches for drupal/video https://www.drupal.org/files/issues/2018-07-18/2986682-2.patch (Add source and destination module for migrate plugin) Could not apply patch! Skipping. The error was: Cannot apply patch https://www.drupal.org/files/issues/2018-07-18/2986682-2.patch

drupal/entity_print suggests installing mikehaertl/phpwkhtmltopdf (PhpWkhtmlToPdf provides the PHP library to use Wkhtmltopdf) Generating autoload files > DrupalProject\composer\ScriptHandler::createRequiredFiles

Again, Composer is non-standard on Synology; they want you to use their own Package Manager. Others have gotten it to work and I was following their instructions for installation, but I don't think any of them were installing Opigno. How might I go about applying patches manually, at least to the Groups module (which seems to be the problem child preventing the installation from proceeding)?

ehbowen
Offline
Last seen: 3 weeks 5 days ago
Joined: 09/06/2018
Digging into the problem with

Digging into the problem with a more verbose output, I see that I'm apparently missing the 'patch' command altogether...which is why the patches are not being applied. But so far I'm drawing a blank on where to find this command and how to install it on a Synology NAS. Any suggestions?