3 posts / 0 new
Last post
ahmad786
Offline
Last seen: 4 months 6 days ago
Joined: 01/23/2016
Upgrade Opigno

Hello all,

I tried to upgrade from Opigno 1.38 to Opigno 2.3

I got this error at the upgrade page :

"The video plugin must define the source_module property."

Please, could someone help me ?

thanks in advance

boyd.badten
Offline
Last seen: 2 months 3 weeks ago
Joined: 05/06/2016
Same exact thing here---what "video plugin"??

I'm going from Opigno 1.31 to 2.5. Everything else seems to be going pretty well except the upgrade is stalled with the message "The video plugin must define the source_module property."

In the Opigno 2 user manual page on upgrading it says: Step 7: On page ‘Upgrade analysis report’ click on button ‘Continue anyway’. ......but I cannot get past the video plugin error and get to the 'Upgrade analysis report' page. Analysis report page is not generated.

I have no idea how to resolve this---even after a lot of experimentation and research. Any ideas?

timotheonb
Offline
Last seen: 3 days 22 hours ago
Joined: 12/07/2017
Unable to upgrade core. Composer and User interface.

It appears that the incapacity for opigno_lms-8.x-2.6-core.tar.gz to upgrade is due to some kind of Platon Theme conflict. Every time I try to upgrade, I get an error message related to the Platon theme version conflicting with either one version or the other. Problem 1 - opigno/opigno_lms 1.6.0 requires drupal/platon 1.2.0 -> satisfiable by drupal/platon[1.2.0] but these conflict with your requirements or minimum-stability. - opigno/opigno_lms 1.6.0 requires drupal/platon 1.2.0 -> satisfiable by drupal/platon[1.2.0] but these conflict with your requirements or minimum-stability. - Installation request for opigno/opigno_lms 1.6.0 -> satisfiable by opigno/opigno_lms[1.6.0]. Every time I try to install in the admin user interface I get the following message: opigno_lms-8.x-2.6-core.tar.gz does not contain any .info.yml files.