5 posts / 0 new
Last post
sibil
Offline
Last seen: 1 day 10 hours ago
Joined: 08/22/2019
Unable to install using Composer

Installation via composer is giving multiple errors, many failures to apply patches.

Followed the documentation from here: https://opigno.atlassian.net/wiki/spaces/OUM20/pages/361922562/Installat...

Errors during installation:

admin
Offline
Last seen: 1 day 3 hours ago
Staff
Joined: 09/07/2012
Hi sibil,

Hi sibil,

Maybe drupal.org was down when you tried it?

Have you confirmed that your server can access drupal.org? Maybe its beeing blocked?

Try wget https://www.drupal.org/files/issues/2018-07-18/2986682-2.patch to check.

 

Best regards

sibil
Offline
Last seen: 1 day 10 hours ago
Joined: 08/22/2019
wget works.

wget works.

Appreciate your support.

Server is able to download the patch, but applying the patch fails.

Composer is still giving the same error. composer create-project opigno/opigno-composer example-folder

Please note that all the 16 patches are failing.

cat composer.log | grep "Could not apply patch" | wc -l

16

Composer version 1.9.0

CentOS Linux release 7.6.1810 (Core)

PHP 7.2.21

git version 1.8.3.1

sibil
Offline
Last seen: 1 day 10 hours ago
Joined: 08/22/2019
After copying the patches to

After copying the patches to the respective directories, I'm able to apply the patches individually.

cp 2986682-2.patch ./example-folder/web/modules/contrib/video/

cd ./example-folder/web/modules/contrib/video/

git apply 2986682-2.patch

sibil
Offline
Last seen: 1 day 10 hours ago
Joined: 08/22/2019
patch was not installed.

patch was not installed.

"yum install patch" fixed the issue.

Running composer install on verbose mode would give meaningful error messages. Thanks!

Thanks!