1 post / 0 new
ljxhanswers
ljxhanswers's picture
Offline
Last seen: 1 month 6 days ago
Joined: 01/29/2019
drush updatedb [error] Update aborted by: menu_link_content_post_update_make_menu_link_content_revisionable

I followed the manual "Upgrade with Composer" https://opigno.atlassian.net/wiki/spaces/OUM20/pages/363134999/Upgrade+w... I used the latest composer.json 2.7 after >composer update >drush updatedb

this error appears: [error] Update aborted by: menu_link_content_post_update_make_menu_link_content_revisionable

My site is not accessible now, I cant get access to my sites admin pages.

I have tried finding similar problems on drupal.org, and used the patches, but without any success, for example: Failed while updating from 8.6.15 to 8.7.x: Update aborted by: menu_link_content_post_update_make_menu_link_content_revisionable https://www.drupal.org/project/drupal/issues/3052905

Has anyone else had similar problems?

Now I am getting further errors regaring restui and jwt: Deprecation warning: require.drupal/restui: is invalid, it should have a vendor name, a forward slash, and a package name. The vendor and package name can be words separated by -, . or _. The complete name should match "a-z0-9/a-z0-9". Make sure you fix this as Composer 2.0 will error.