5 posts / 0 new
Last post
meant
Offline
Last seen: 2 years 2 months ago
Joined: 07/26/2015
Private folder

Dear opigno team,

i am looking to find a description how a private folder setup "drupal" has to be done? It is impotant that only registered users can see the media. After checking the private folder box and uploading a picture with imce-> there is only a red cross appearing... Is there more configuration (roles...) to be done ?

Thanks for your support and great lms!

meant
Offline
Last seen: 2 years 2 months ago
Joined: 07/26/2015
IMCE

The problem exists only in combination with the imce file upload. I found a description and offered modul here: https://www.drupal.org/project/imce_private_files Could it be a solution?

James Aparicio
James Aparicio's picture
Offline
Last seen: 4 months 2 weeks ago
Staff
Joined: 10/30/2013
Hi meant,

Hi meant,

This red cross you are refering to, displays for all users? Even user 1?

Best regrads

meant
Offline
Last seen: 2 years 2 months ago
Joined: 07/26/2015
Thanks for your answer. =)

Thanks for your answer. =)

Yes, the document is just shown as a broken symbol to every kind of users... even if i take the user 1 role. - After unchecking "Disable serving of private files" at the IMCE configuration, i can see the pictures... but their path is no longer private. - it looks like a ckeditor/wysiwyg issue: https://www.drupal.org/node/1259510 - or maybe an IMCE issue: https://www.drupal.org/node/1265532

meant
Offline
Last seen: 2 years 2 months ago
Joined: 07/26/2015
Additional information

I have tried various settings ... unfortunately unsuccessful. Can I still help with further information/settings solving the problem?