12 posts / 0 new
Last post
dario.n.suardiaz
Offline
Last seen: 1 year 10 months ago
Joined: 10/12/2017
Error with Moxtra Server

Hello! I am having problems today to create collaborative workspaces and live meeting for courses.

If I try to create a collab workspace it throws "Error while contacting the Moxtra server. Try again or contact the administrator" If I try to add a live meeting for a course and don't get any errors while creating it, but the meeting is always created as ended

Yesterday I was able to create a live meeting without any issues, is there any kind of problem with the service?

Many Thanks! Best regards,

Dario

axel
Offline
Last seen: 42 min 47 sec ago
Staff
Joined: 09/25/2013
Hi Dario,

Hi Dario,

I just tested and the service is working correctly right now.

Are you behind a proxy?

Best regards,

dario.n.suardiaz
Offline
Last seen: 1 year 10 months ago
Joined: 10/12/2017
Hi Axel,

Hi Axel, Sorry for the delayed response. As you commented, seems that the moxtra server is running fine as I can schedule now a Live Meeting or set up a Colab Workspace with no problem but I'm getting an error message "www.moxtra.com redirected you too many times." when trying to load the application :\

Could this be maintenance related or something? Right now for me is 1:30 AM UTC and last time was provably around 00:00 UTC

To reply your earlier question, I'm not behind any proxy

Any ideas?

axel
Offline
Last seen: 42 min 47 sec ago
Staff
Joined: 09/25/2013
Hello

Hello

When do you get this error? When entering a live meeting or a collaborative workspace?

Could you post a screenshot of this error? Do you have additional error details in recent log messages ?

dario.n.suardiaz
Offline
Last seen: 1 year 10 months ago
Joined: 10/12/2017
Hello Axel,

Hello Axel, I'm sorry, yes, I get the error when i try to access the Live Meeting or Workspace. Screenshot https://photos.app.goo.gl/eulOv6SKrxuXyWOX2

dario.n.suardiaz
Offline
Last seen: 1 year 10 months ago
Joined: 10/12/2017
Hi Axel,

Hi Axel,

I just found something that might be related (or not) to my issue... there are 2 users in my platform which are currently blocked (nico.llanas and estudiante_prueba), if I try to enable any of them it throws me a "Error while getting the user information from Moxtra servers" error in the users administration: https://photos.app.goo.gl/jYgQGzhD4ugUyutx1

I tried cancelling the accounts but then again I got an error (screenshot: https://photos.app.goo.gl/HfKZYaJyWikK8tMO2) and after clicking the error page link it takes me back to the users administration and I see again the "Error while getting the user information from Moxtra servers" but only that this time with a green checkmark: https://photos.app.goo.gl/CqqjwGZKejDerZPa2

Could it be that these users are somehow blowing up my moxtra app? if are you able to forcebrute the accounts cancellation feel free to do it, i'm using the instance as a proof of concept for a serious project but without the moxtra meetings i'm falling a little short on functionality :(

Thanks for all your help on this!!!

axel
Offline
Last seen: 42 min 47 sec ago
Staff
Joined: 09/25/2013
Hi Dario

Hi Dario

Could you please send us your Moxtra organization ID (that you can see at Moxtra config page on your Opigno instance, at /admin/opigno/system/moxtra) ?

You can also send it through the contact form on opigno.org website if you don't want to have it publicly disclosed on this forum

Best regards

dario.n.suardiaz
Offline
Last seen: 1 year 10 months ago
Joined: 10/12/2017
Hey Axel,

Hey Axel,

I just sent the ID through the contact form with a little brief on the issue. I have also tried to access using a different instance i have set up (lunic.myopigno.org) that has no users but the administrator and I got the same "www.moxtra.com redirected you too many times." error, I've sent the Org ID for that instance as well in the contact message.

Best,

Dario

axel
Offline
Last seen: 42 min 47 sec ago
Staff
Joined: 09/25/2013
Hi Dario

Hi Dario

Thanks, we received your email !

We also experienced the problem this morning, it seems this is a general problem with Moxtra.

We are checking with them what happens, we will post some updates on this forum thread as soon as we know more.

Sorry for the inconvenience

axel
Offline
Last seen: 42 min 47 sec ago
Staff
Joined: 09/25/2013
Hi Dario,

Hi Dario,

We found a fix for that problem.

It is fixed for the Opigno cloud instances.

For on-premise instances, the Opigno Moxtra app will have to be updated (we still did not release a new version).

If you want to fix it on your on-premise installation, it's very easy, you simply have to edit the file /profiles/opigno_lms/modules/opigno/opigno_moxtra_app/templates/moxtra_app_js_init.tpl.php and add at the end of the script sdk_version: '3'

It will consequently look like this (in blue what should be added)

<script>
  Moxtra.init({
    mode: '<?php echo OPIGNO_MOXTRA_APP_MOXTRA_JS_ENV; ?>',
    client_id: '<?php echo variable_get('opigno_moxtra_app_client_id'); ?>',
    org_id: '<?php echo variable_get('opigno_moxtra_app_org_id'); ?>',
    access_token: '<?php echo opigno_moxtra_app_api_opigno_get_access_token() ?>',
    sdk_version: '3'
  });
</script>
James Aparicio
James Aparicio's picture
Offline
Last seen: 2 weeks 1 day ago
Staff
Joined: 10/30/2013
The fix commit,
dario.n.suardiaz
Offline
Last seen: 1 year 10 months ago
Joined: 10/12/2017
This is awesome!

This is awesome!

I just tested in my cloud instance and I have been able to join a Moxtra meeting. Thank you so much guys for helping me out on this!!!

Best Regards!

Dario