9 posts / 0 new
Last post
rodolfo
Offline
Last seen: 4 months 2 weeks ago
Joined: 03/09/2015
Problem translating lessons

Hi

First of all, congratulations for your great work with opigno, I love it!

currently I am trying to develop a course in opigno, I want my site to be multilingual so I added a spanish translation to my site. I added the entity translation module and the title module which is required for entity translation to work in DP7.

the interface translation works fine.

but when I try to translate a lesson it says: No translatable fields

any idea what could be wrong?

James Aparicio
James Aparicio's picture
Offline
Last seen: 4 months 3 weeks ago
Staff
Joined: 10/30/2013
Hi Rodolfo,

Hi Rodolfo,

This is because most of the fields that quiz implements are not entities. 

You can either change the fields of the quiz to entities or use normal node translation for the quizzes.

Best regards

rodolfo
Offline
Last seen: 4 months 2 weeks ago
Joined: 03/09/2015
Content translation now enabled

I enabled the module for multingual translation and content translation

Now I am able to translate the lesson, but when I go to the course where all lessons are displayed, also the translated one is displayed. for example: I created "lesson 1" for English and translated it as "leccion 1" for spanish but they are both displayed regardless of the language my site is.

if my site is showing in Spanish I dont want the link for "lesson 1" to be displayed, I think this should be hidden.

I tried all options to hide it, but it's not posible.

James Aparicio
James Aparicio's picture
Offline
Last seen: 4 months 3 weeks ago
Staff
Joined: 10/30/2013
Hi rodolfo,

Hi rodolfo,

For the page with the list of quizzes, you need to alter the view and add a filter to it. User current language.

For the left block you should look in the opigno_quiz_app.module and filter it out aswell.

Best regards

rodolfo
Offline
Last seen: 4 months 2 weeks ago
Joined: 03/09/2015
Done

Yes it worked, I added a filter for my courses and quizzes . now I am able to see only the lessons corresponding to the selected language.

thanks a Lot

Christinelle
Offline
Last seen: 3 months 2 weeks ago
Joined: 10/14/2016
Hi James,

Hi James,

I'm trying to display my content according to the user language. I have had a filter to the training view has recommended in your post, and it works fine. But I can find how to display only the right course in a class, the both english and french are displayed... Is there know a simple way to do that ? Many thanks

James Aparicio
James Aparicio's picture
Offline
Last seen: 4 months 3 weeks ago
Staff
Joined: 10/30/2013
Hi Christinelle,

Hi Christinelle,

Some more detailed information would be nice. I did not understand. Maybe some screenshots?

 

Best regards

Christinelle
Offline
Last seen: 3 months 2 weeks ago
Joined: 10/14/2016
Hi James,

Hi James,

Sorry I have wrote my message too quickly :-). How can I send your screenshots ? More details below.

I have a new class in my opigno and in this class, part of the students speaks French, the other part speaks english. So I would like to display a french course to french-speaking (and only the french), and the english translation of this course to the english-speaking (only the english version).

Opigno settings : I have enabled various modules to be able to translate my course : Content Translation, i8n, Entity Translation... Not sure Entity Translation is usefull in my case... I'm able to translate my content (course, quizzes...) thanks to Content Translation (the translate tab is missing but I can access the translation screen at the url node/%0%/translate). Language detection is based on the user language preference for the interface and content.

My problem is that there is no "filter" according to the language . I thought the modules would manage the translations and display the content according to the user language preference..., but the both french and english version are still displayed. For the course list (My trainings) I have add a filter in the view settings to display only content according to the user language, and It's OK. But in the node classe, I don't know how to display only the "right" links.

Hope you could give me a solution, maybe my settings are not perfect...

Many thanks for help :-)

Regards

Christinelle
Offline
Last seen: 3 months 2 weeks ago
Joined: 10/14/2016
Hi James,

Hi James,

As it is not working as I expected, I finally created two classes: one in French, and the other in English. Each contains the French course or the English course. As they are private classes, I link the participants to the "right" class according to their language preference. It works fine and as I don't have too many trainings, it is quite easy to manage :-)

Regards